読者です 読者をやめる 読者になる 読者になる

気の向くままに書き綴る

勉強会参加したメモや日々の思ったことのメモ等

OS X 10.9 Mavericksアップデート後?2:bundle install ができない

複数のMac製品で開発していて、一台だけなぜか急にbundle install が通らなくなった

$ bundle install

An error occurred while installing atomic (1.1.14), and Bundler cannot continue.
Make sure that `gem install atomic -v '1.1.14'` succeeds before bundling.

 

atomic ??

今までコケたことがないことと、他の環境では問題なく動いていることを踏まえて、

下位モジュールを疑うことにした

多分OSのVersionアップが原因臭い。

ということで、Homebrewを最新Verまで挙げる

$ brew update

$ brew upgrade

ここで

Warning: No developer tools installed.
You should install the Command Line Tools.
Run `xcode-select --install` to install them.
Warning: You have not agreed to the Xcode license.

とのエラーが!

$ brew doctor

→上と同じようなエラー

MountainLioneでXcode入れたのにまたCommandLineToolがないの!?Σ(゚Д゚;エーッ!

 

んな!ばかな!

Xcode開いて、前回行った作業をもとに確認。以下参考URL。

Mac OS X Lionにしたらgccがなくてnode.jsがコンパイルできなくなった件

そもそも、

Xcode->Preferences->Downloads でCommand Line Tools がどこにも見当たらない^^;

 

気を取り直して、

brew upgrade で出力されているコマンドを叩く

 

$ xcode-select --install

xcode-select: note: install requested for command line developer tools

後は、ライセンス同意などすれば無事入ります。

$ bundle install

成功!!!